v16.3 C/S環境で通信不具合

Go down

v16.3 C/S環境で通信不具合

投稿 by osaru on 2018-03-31, 5:26 pm

v16.3 クライアント/サーバー環境で、クライアントがフリーズしたり、サーバーへの接続が出来なくなったりする事が、時々(月1回程度)発生します。サーバーは正常に動作しているように見えコンソールの切り替えなど問題なく行えるときと、サーバーもフリーズする時の2種類のケースがありますが、今回遭遇したのは前者です。

ご覧の通り、サーバーへの接続件数にズレが生じ、ユーザーリストでは反応しなくなったユーザーも未だ残っている状況ですが、ライセンス消費数は正常稼働していると思われる台数の表示がされており、収拾後は上記のズレは無くなり一致した数字に戻りました。

この時、問題なく操作が行えているクライアントと、フリーズして操作の行えないクライアントが混在している状況が十数分程度続き、フリーズしたクライアントを強制終了して再起動し再接続が行えるようになったら収拾しました(しばらくの間は全く再接続できませんでした)。その間、問題の発生しなかったクライアントはトラブル発生にすら気づいて居ない状況です。

先日v16.3 Hotfix 2も出ておりますので、折を見て試したいとは思っておりますが、Fixリストに関連しそうな内容も見当たらないのでモチベーションは上がっていません。
何か見直した方がよいポイントなどアドバイス頂ければ幸いです。

osaru

投稿数 : 34
登録日 : 2017/08/14

トップに戻る Go down

Re: v16.3 C/S環境で通信不具合

投稿 by hosaka on 2018-04-02, 11:07 am

こんにちわ、
おそらく4Dの日本語フォーラムで私が騒いでいるゾンビユーザーの件と同じだと思います。
http://forums.4d.com/Post/JP/19293643/1/19293644

クライントのスリープ/復帰絡みだとおもわれるので、
1.クライントでスリープ設定を"しない"に設定する。
2.モバイル端末の場合、必ず4Dを終了してもらう様にお願いする。
3.SET DATABASE PARAMTERの設定する時間を短くする。
で大分マシになると思います。

フォーラムでもふれていますが、まだ完全に直ってはいない様です。現在ネットワークログを提出して、解析してもらっています。
avatar
hosaka

投稿数 : 130
登録日 : 2016/07/04
所在地 : 大阪

トップに戻る Go down

Re: v16.3 C/S環境で通信不具合

投稿 by osaru on 2018-04-07, 5:13 pm

hosaka様、アドバイスありがとうございます。

クライアント側は、スリープ設定を"しない"にいつも設定しておりますが、手動でスリープする方がちらほら居るみたいで(^^;
SET DATABASE PARAMETER(Idle connections timeout;15)  //15秒
としておりますが、もっと短い方が良いと言うことでしょうか?

現在WiFi環境のクライアントはありませんが、VPN経由のクライアントがるので余り短くしすぎるのもどうかと思ったりしています。ひとまず5〜10位から試してみたいと思います。

osaru

投稿数 : 34
登録日 : 2017/08/14

トップに戻る Go down

Re: v16.3 C/S環境で通信不具合

投稿 by hosaka on 2018-04-09, 3:18 pm

osaru wrote:hosaka様、アドバイスありがとうございます。

クライアント側は、スリープ設定を"しない"にいつも設定しておりますが、手動でスリープする方がちらほら居るみたいで(^^;
SET DATABASE PARAMETER(Idle connections timeout;15)  //15秒
としておりますが、もっと短い方が良いと言うことでしょうか?

現在WiFi環境のクライアントはありませんが、VPN経由のクライアントがるので余り短くしすぎるのもどうかと思ったりしています。ひとまず5〜10位から試してみたいと思います。
ごめんなさい。違います。
https://github.com/4D-JP/release-notes/tree/master/v16/16.3/hf1/
の注記で記載されている非公開のパラメータです。一応、非公開らしいのでここに直接書きません。
ディフォルトは48時間に設定されているのですが、私のところでは30分に設定し直しています。
avatar
hosaka

投稿数 : 130
登録日 : 2016/07/04
所在地 : 大阪

トップに戻る Go down

Re: v16.3 C/S環境で通信不具合

投稿 by osaru on 2018-04-09, 5:13 pm

hosaka様、ご連絡ありがとうございます。
ディフォルトは48時間に設定されているのですが、私のところでは30分に設定し直しています。
なるほど、こちらは未だ16.3でHotFix充てていませんので少し見送りです。
近々サーバーのアップデートに合わせて再起動イベントがありますので、そちらに併せてHotfix導入を検討します。

osaru

投稿数 : 34
登録日 : 2017/08/14

トップに戻る Go down

Re: v16.3 C/S環境で通信不具合

投稿 by osaru on 2018-07-15, 3:03 pm

4D v16.3 Hotfix4にて運用しておりますが、ウチの使い方でゾンビユーザーが発生する率もかなり少なくなりました。小一週間程度ですが同じIPのユーザー接続がコンソールに残ることも見なくなりました。

osaru

投稿数 : 34
登録日 : 2017/08/14

トップに戻る Go down

Re: v16.3 C/S環境で通信不具合

投稿 by Sponsored content


Sponsored content


トップに戻る Go down

トップに戻る


 
Permissions in this forum:
返信投稿: 不可